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Introduction
Whilst the dedicated enthusiast  can, with the aid of a dedicated
HRPT receiver and steerable antenna, download HRPT data
directly from the NOAA satellites, relatively few choose to do so.
There are two reasons for this. First, the not inconsiderable cost
of hardware, particularly for the steerable antenna assembly,
and second actual siting of the antenna. 

But there is an easier way. The same raw HRPT data files
transmitted from the NOAA satellites are available on the
Internet and can be downloaded free from a number of sources,
most notably from NOAA’s own Comprehensive Large-Array
Stewardship System (CLASS), an environmental data library—
formerly known as the Satellite Active Archive (SAA). If you
cannot afford to purchase a commercial HRPT system and lack
the expertise to build your own from a kit this provides an
alternative means of accessing the fascinating world of high-
resolution  satellite imagery.

Registering with CLASS
Although you must first register with CLASS before they will
permit you to download their products, this is just a formality—
and there is no charge. Just direct your Internet browser to:

http://www.class.noaa.gov

and click the ‘Register’ link at the top right-hand corner of the
screen. The only information you have to supply are your first
name, last name, e-mail address and password.  The password
is of your own choosing, and is required when you log-in to the
site.

Logging-in
Once registered, you can log-in to the CLASS site and select
files for download. Do this by clicking on the ‘Login’ link at the
upper right-hand corner of the opening screen.

Type your first name into the ‘Username’ field and your chosen
password into the ‘Password’ field. (figure 1) then click OK. Wait
a few seconds until the screen refreshes (the ‘Login’ link will
now have disappeared) and open the ‘Please select a product
to search’ window, part of which is shown in figure 2. Click on
the first item in the list, ‘Advanced Very High Resolution
Radiometer’, then on the link labelled ‘Go’. You are now taken to
the page where you can select the type of image you wish to
search for, a specific satellite, and the start and end dates for
your search. The relevant part of this page is shown in figure 3.

Available Data Types
There are three types of data that you can select. The
uppermost item, GAC, provides global coverage from satellites
at a similar resolution to the familiar 137 MHz APT. These files
produce images with a maximum ground resolution of just four
kilometres per pixel. You are almost certain to be able to locate
an image from anywhere on the planet in this file format. HRPT
provides the full-resolution 1-km/pixel raw data stream received
live from the satellites at ground stations in the USA, ideal if you
require images of North America and the Caribbean. LAC also
provides the HRPT data stream, but these files are recorded
aboard the satellites whilst flying over regions out of direct range
of US ground stations; the data are  relayed to Earth during a
subsequent orbit. 

If you require HRPT data files for Europe, Asia or Australasia,
then you should check the box beside LAC. Because of the
recovery method for these data, you may often have to wait till

Figure 1 - The Login window

Figure 2 - Selecting NOAA data

Figure 3 - Selecting a Dataset
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the following day before LAC files become available for
downloading.

Selecting a Dataset
The options for Receiving Station and Distribution Site can
safely be left untouched at their default settings. The Node
options afford the opportunity of restricting your search to
ascending or descending satellite passes: leaving all options
unchecked has the same effect as checking the ‘either’ option.
Should you wish to restrict your search to just one specific
Satellite, click on its name to highlight it—otherwise passes for
all satellites will be searched for and displayed.

The Temporal setting allows you to refine the search interval
(one week prior to the current date by default). Either or both of
two interactive calendars above the map at the foot of the page
may be modified to increase the breadth of search, or to restrict
it to a single day  (figure 4). You can also restrict the hours
searched by entering Start Time and End Time in the fields
provided. Finally, you must define Spatial details for the area
over which you wish to search for satellite data by dragging a
rectangle over the map (see Appendix: ‘Java’) to outline the
target region. You can zoom in for increased accuracy (figure 5).

User Preferences
The menu in the left-hand margin of each page contains the
option ‘User Preferences’. It is here that you can choose which
of the five HRPT channels you require for the various file
formats. Do this prior to ordering your first datafile from CLASS.
Be certain that you select 10 bits/pixel for each (figure 6). These
preferences remain in force for future downloads until such time
as you decide to change them.

Ordering Datasets
Once all the above has been completed, click on the Search
button beneath the map and await a listing of all the appropriate
satellite passes (figure 7). If you are searching over an extended
time interval this may take a little time and present you with a
large number of datasets in a paged list. Generally, it is helpful
to restrict the search to a specified 24-hour period. You can view
thumbnails of any image by clicking the button in the
View Details column at the left of each line in the table
(figure 8).

If you are happy with the image, return to the Search results
screen, check the box in the Shopping cart column then click
the Go to cart button at the top of the page. This takes you to
the Shopping cart screen (figure 9) where all that remains to be
done is to click the Place order button at upper left. Note: the
‘Include Archive Header’ box is always checked by default - do
not alter this. 

You should receive confirmation of your order almost
immediately, and an e-mail (to the address you provided when
you registered) confirming this is also sent out shortly thereafter.

The datasets that you order are placed in a folder on the CLASS
FTP server for you to download. There will be a delay while this
is set up for you, but you should receive a second e-mail
confirming the address; this often arrives within minutes though
it can take several hours during busy periods. Note, however,
that if you request data that is more than a week old, it may
sometimes be several days before it is made available for you.
HRPT datasets can be large (some are of the order of 100 Mb).
In general, a 10° spread in latitude equates to 16 Mb of data. As
image processing can take a considerable time, particularly on
low specification computers, it doesn’t pay to order a file larger

Figure 6 - User preferences

Figure 5 - Selecting the area (zoomed)

Figure 7 - Search results

Figure 4 - Selecting a date from the calendar
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Figure 8 - Dataset details

Figure 9 - Shopping cart

Figure 10 HRPT Reader screen displaying overnight snowfall in
the Low Countries - NOAA 17, February 29, 2004
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Figure 11 - Processing times on various PCs

than you require! The whole point of HRPT, surely, is to
investigate small regions in high detail.  

Additionally, if you are using a dial-up Internet connection, it
again pays to order the smallest datafile that suits your needs,
as even a 16 Mb file as noted above will take the best part of an
hour to download.  You can reduce file size by ordering only
channels 2+4 if all your interest is in producing false-colour
images.

If you plan to download HRPT telemetry files on a regular basis,
you should seriously consider switching to a broadband Internet
account.

Once you receive notification that your file is available for
download you have just 72 hours to retrieve it before it is
cleared. You can retrieve your file with an ftp program of your
choice or via your web browser. Note that when downloading via
ftp you must select a ‘binary’ (or ‘image’) mode of transfer, not
‘text’ or ‘ascii’.

HRPT Imaging Software
Once you have downloaded an HRPT or LAC datafile you have
to process it into images. The software preferred by the majority
of enthusiasts is the HRPT Reader Program [1] written by David
Taylor.  This program can be obtained in both free and
registered versions. The free version is perfectly adequate for
getting started but a number of more sophisticated image
processing options are available upon registration. If you have
not run any of David’s software before, you will also require to
install the Runtime Library Bundle.

HRPT Reader comes as a ZIP file. As it does not have an
installer you must create a folder on your hard drive called
‘HRPT Reader’ and unzip all the contents into this. It is also
advisable to create two sub-folders within it, RAW and IMAGES,
the former to store your downloaded datafiles, the latter to hold

the images you prepare from them.

Creating HRPT Images
The files from CLASS have meaningless automatically
generated filenames: for example  ‘A4416181.L5629091’. This
can be read by HRPT Reader, but it is best to edit the extension
to ‘GAC’, ‘HRP’ or ‘LAC’ to give a filename like ‘A4416181.HRP’.
The stem of the filename can also be changed to a more
meaningful name if you wish. Using these extensions ensures
that the decoding software ‘understands’ the architecture of
each specific datafile, and interprets it correctly.

Use the <File → Open> menu to navigate to your RAW folder
and double-click on an HRPT datafile. If you have a relatively
high-specification computer, HRPT Reader should display the
image after just a few seconds. Figure 11 compares processing
times for a variety of PCs, using raw datafiles of two different

sizes. Although a faster processor bring benefits, the key to
speed is having lots of RAM.

The images from all five of the HRPT channels are available for
inspection simply by clicking the appropriate channel tab at the
top of the screen (figure 10). A number of specialised images
produced by combining these channels in various ways can also
be viewed on the other tabs (False colour, RGB, Sea surface
temperature etc), but a detailed description of these is beyond
the scope of this article.

Saving Images
Before saving an image for the first time it is necessary to ‘tell’
HRPT Reader the location of your ‘IMAGES’ folder. Select
<Options → Results location> from the menu-bar to navigate  to
this folder then click on it. Now any file saved using the options
under the <File> menu will be placed in that folder. The
particular image saved is always the one actually displaying at
the time of the save; if you save while the false-colour image is
displayed on the screen, it is that false-colour image that will be
saved, and so on.
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This splendid NOAA-16, false-colour image was prepared
from a CLASS ‘HRP’ datafile dating from 21:40 UT on June
28, 2003. The image displays a cluster of fascinating ‘ship
tracks’ over the Pacific Ocean. Vancouver Island and the

snow-capped Coast Range are prominent, as are the
Columbia and Snake Rivers. The volcanic peaks of the
Cascade Range stand out like a regiment of white beacons.
Telemetry data: NOAA CLASS  Processing: HRPT Reader

This scene was observed by NOAA-17 at 03:11 UT on
June 12, 2003. The raw datafile was acquired from
Russia’s SMIS server. The centre of the image is

dominated by the Caucuses Mountains stretching
between the southern Caspian Sea and the Black Sea.
Telemetry data: SMIS  Processing: HRPT Reader



Page 5

How to obtain NOAA HRPT Telemetry data from the NOAA CLASS Archive and decode them using HRPT Reader

Images can be stored in a variety of formats. <File → Save
displayed image> saves the geometrically uncorrected
HRPT image (exactly as it appears on screen) in lossless
BMP format at 1.1 km/pixel resolution. The <File → Save
with correction>  option applies geometric correction to
counteract perspective effects caused by Earth’s
curvature, which occur at the edges of the images.
<File → Save as APT> produces a corrected but
subsampled version of the latter, with a resolution of
4-km/pixel. There are also options to save in the
compressed JPEG format.

Java
In order to visualise and make use of the interactive map
feature on the CLASS web page (figure 5) you require to
have J2SE, the Sun Java™ 2 Platform v 1.4.2, Standard
Edition installed on your PC. This is not provided with
Windows XP, and some users have queried why they are
not able to make use of the map. You can download the
installation file for Java from:

http://java.sun.com/j2se/1.4.2/

Once this is installed, all the features of the CLASS
website should be accessible in your web browser. Of
course, even without the map, you can still enter relevant
latitude and longitude values to define your region of
choice, manually, into the fields immediately above the
‘zoom’ buttons.

Other Sources for HRPT Files
HRPT data from the NOAA satellites is downloaded daily
by the Space Monitoring Information Support Laboratory
(SMIS) in Moscow, Russia [2].  There is a wealth of material
available on the ‘Satellite Data Page’ [3]. The link
‘Telemetry Active Archive’ allows you to download datafiles
collected during the previous 28 days and files for the
previous 24 hours are available from the
‘Last telemetry files’ link. HRPT files are also available
from the ZS RCPOD, Novosibirsk server [4]. This has the
advantage of access to NOAA passes farther east than
Moscow.
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A NOAA-17 HRPT segment from February 29, 2004, when much of Scotland
and northern England were blanketed in snow.

Processed in ‘vegetation’ mode.

55


